use strict;
my $str = 'Hello, world!
Aren\'t you clever?
\'Later\', she said.
\'Maybe 5 o\'clock?\'
In the year 2017 ...
G2g, cya l8r
hello_world.h
Hermione\'s time-turner.
Good mor~+%g.
Hi\' Testing_ Bye-';
my $regex = qr/[A-Za-z0-9]+(['_-]?[A-Za-z0-9]+)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}