import Foundation
let pattern = #"[A-Za-z0-9]+(['_-]?[A-Za-z0-9]+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Hello, world!
Aren't you clever?
'Later', she said.
'Maybe 5 o'clock?'
In the year 2017 ...
G2g, cya l8r
hello_world.h
Hermione's time-turner.
Good mor~+%g.
Hi' Testing_ Bye-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)