#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\{ (?:(?<method>.+?)\s+\{)?|\G)[,\s]*(?<key>\$\w+)(?: = (?<value>[^,\n;}]*))?"
Local $sString = "{ method_name { $key1 = 'quoted value' , $key2 = __('literal value'); }}" & @CRLF & _
"" & @CRLF & _
"{{ $key1 = 'quoted value' , $key2 = __('literal value') }}" & @CRLF & _
"" & @CRLF & _
"{ method_name { $key1 = , $key2 = __('literal value'); }}" & @CRLF & _
"{ method_name { $key1, $key2 = __('literal value'); }}" & @CRLF & _
"" & @CRLF & _
"{ method_name { $key1 = 'quoted value' , $keyN = 3.14; }}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")