const regex = /(?:\{ (?:(?<method>.+?)\s+\{)?|\G)[,\s]*(?<key>\$\w+)(?: = (?<value>[^,\n;}]*))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\{ (?:(?<method>.+?)\\s+\\{)?|\\G)[,\\s]*(?<key>\\$\\w+)(?: = (?<value>[^,\\n;}]*))?', 'gm')
const str = `{ method_name { \$key1 = 'quoted value' , \$key2 = __('literal value'); }}
{{ \$key1 = 'quoted value' , \$key2 = __('literal value') }}
{ method_name { \$key1 = , \$key2 = __('literal value'); }}
{ method_name { \$key1, \$key2 = __('literal value'); }}
{ method_name { \$key1 = 'quoted value' , \$keyN = 3.14; }}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}