re = /(?:\{ (?:(?<method>.+?)\s+\{)?|\G)[,\s]*(?<key>\$\w+)(?: = (?<value>[^,\n;}]*))?/m
str = '{ method_name { $key1 = \'quoted value\' , $key2 = __(\'literal value\'); }}
{{ $key1 = \'quoted value\' , $key2 = __(\'literal value\') }}
{ method_name { $key1 = , $key2 = __(\'literal value\'); }}
{ method_name { $key1, $key2 = __(\'literal value\'); }}
{ method_name { $key1 = \'quoted value\' , $keyN = 3.14; }}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end