import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\{ (?:(?<method>.+?)\\s+\\{)?|\\G)[,\\s]*(?<key>\\$\\w+)(?: = (?<value>[^,\\n;\\}]*))?";
final String string = "{ method_name { $key1 = 'quoted value' , $key2 = __('literal value'); }}\n\n"
+ "{{ $key1 = 'quoted value' , $key2 = __('literal value') }}\n\n"
+ "{ method_name { $key1 = , $key2 = __('literal value'); }}\n"
+ "{ method_name { $key1, $key2 = __('literal value'); }}\n\n"
+ "{ method_name { $key1 = 'quoted value' , $keyN = 3.14; }}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}