use strict;
my $str = '{ method_name { $key1 = \'quoted value\' , $key2 = __(\'literal value\'); }}
{{ $key1 = \'quoted value\' , $key2 = __(\'literal value\') }}
{ method_name { $key1 = , $key2 = __(\'literal value\'); }}
{ method_name { $key1, $key2 = __(\'literal value\'); }}
{ method_name { $key1 = \'quoted value\' , $keyN = 3.14; }}';
my $regex = qr/(?:\{ (?:(?<method>.+?)\s+\{)?|\G)[,\s]*(?<key>\$\w+)(?: = (?<value>[^,\n;}]*))?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}