$re = '/(?:\{ (?:(?<method>.+?)\s+\{)?|\G)[,\s]*(?<key>\$\w+)(?: = (?<value>[^,\n;}]*))?/m';
$str = '{ method_name { $key1 = \'quoted value\' , $key2 = __(\'literal value\'); }}
{{ $key1 = \'quoted value\' , $key2 = __(\'literal value\') }}
{ method_name { $key1 = , $key2 = __(\'literal value\'); }}
{ method_name { $key1, $key2 = __(\'literal value\'); }}
{ method_name { $key1 = \'quoted value\' , $keyN = 3.14; }}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);