#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:BOX|APT) *\d{4,}|\D*\d{,3}|\D*(\d{4,}))$"
Local $sString = "HITME 1234" & @CRLF & _
"HITME 12345" & @CRLF & _
"HITME1234" & @CRLF & _
"" & @CRLF & _
"BOX 1234" & @CRLF & _
"BOX 12345" & @CRLF & _
"BOX4044" & @CRLF & _
"APT 1234" & @CRLF & _
"APT 12345" & @CRLF & _
"NONHIT123" & @CRLF & _
"NONHIT 123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")