$re = '/^(?:(?:BOX|APT) *\d{4,}|\D*\d{,3}|\D*(\d{4,}))$/m';
$str = 'HITME 1234
HITME 12345
HITME1234
BOX 1234
BOX 12345
BOX4044
APT 1234
APT 12345
NONHIT123
NONHIT 123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);