import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:BOX|APT) *\\d{4,}|\\D*\\d\\{,3\\}|\\D*(\\d{4,}))$";
final String string = "HITME 1234\n"
+ "HITME 12345\n"
+ "HITME1234\n\n"
+ "BOX 1234\n"
+ "BOX 12345\n"
+ "BOX4044\n"
+ "APT 1234\n"
+ "APT 12345\n"
+ "NONHIT123\n"
+ "NONHIT 123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}