package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:BOX|APT) *\d{4,}|\D*\d{,3}|\D*(\d{4,}))$`)
var str = `HITME 1234
HITME 12345
HITME1234
BOX 1234
BOX 12345
BOX4044
APT 1234
APT 12345
NONHIT123
NONHIT 123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}