import re
regex = re.compile(r"^(?:(?:BOX|APT) *\d{4,}|\D*\d{,3}|\D*(\d{4,}))$", flags=re.MULTILINE)
test_str = ("HITME 1234\n"
"HITME 12345\n"
"HITME1234\n\n"
"BOX 1234\n"
"BOX 12345\n"
"BOX4044\n"
"APT 1234\n"
"APT 12345\n"
"NONHIT123\n"
"NONHIT 123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")