re = /^(?:(?:BOX|APT) *\d{4,}|\D*\d{,3}|\D*(\d{4,}))$/m
str = 'HITME 1234
HITME 12345
HITME1234
BOX 1234
BOX 12345
BOX4044
APT 1234
APT 12345
NONHIT123
NONHIT 123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end