# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!^100$)^[1-9][0-9][0-9]$/$1/gm;t' <<< "101
1000
500
200
99
100
102
999
020
"