const regex = /(?!^100$)^[1-9][0-9][0-9]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!^100$)^[1-9][0-9][0-9]$', 'gm')
const str = `101
1000
500
200
99
100
102
999
020
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);