$re = '/(?!^100$)^[1-9][0-9][0-9]$/m';
$str = '101
1000
500
200
99
100
102
999
020
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;