using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^100$)^[1-9][0-9][0-9]$";
string substitution = @"$1";
string input = @"101
1000
500
200
99
100
102
999
020
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}