import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!^100$)^[1-9][0-9][0-9]$";
final String string = "101\n"
+ "1000\n"
+ "500\n"
+ "200\n"
+ "99\n"
+ "100\n"
+ "102\n"
+ "999\n"
+ "020\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}