using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!Owner):[^:]*?\K(?i:digg|bag)";
string input = @"User:digg
User:bag
User:Don't say digger
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
User:digger
User:bag
User:Don't say digger
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}