re = /(?<!Owner):[^:]*?\K(?i:digg|bag)/
str = 'User:digg
User:bag
User:Don\'t say digger
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
User:digger
User:bag
User:Don\'t say digger
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end