import Foundation
let pattern = #"(?<!Owner):[^:]*?\K(?i:digg|bag)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
User:digg
User:bag
User:Don't say digger
Owner:digger
Owner: Digger
Owner: don't use bag as an insult
User:digger
User:bag
User:Don't say digger
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)