use strict;
my $str = 'User:digg
User:bag
User:Don\'t say digger
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
User:digger
User:bag
User:Don\'t say digger
';
my $regex = qr/(?<!Owner):[^:]*?\K(?i:digg|bag)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}