import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!Owner):[^:]*?\\K(?i:digg|bag)";
final String string = "User:digg\n"
+ "User:bag\n"
+ "User:Don't say digger\n\n"
+ "Owner:digger\n"
+ "Owner: Digger\n"
+ "Owner: don't use bag as an insult\n\n"
+ "User:digger\n"
+ "User:bag\n"
+ "User:Don't say digger\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}