$re = '/(?<!Owner):[^:]*?\K(?i:digg|bag)/';
$str = 'User:digg
User:bag
User:Don\'t say digger
Owner:digger
Owner: Digger
Owner: don\'t use bag as an insult
User:digger
User:bag
User:Don\'t say digger
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);