#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\})|(?=\}))){3,7}\}(?(DEFINE)(?<GetNum>(?!(?:\g{1}|\g{2}|\g{3}|\g{4}|\g{5}|\g{6}|\g{7}|\g{8}|\g{9}|\g{10})\b)\d+))"
Local $sString = "{331,2,989}" & @CRLF & _
"{1,2,3,4}" & @CRLF & _
"{1,2,1,4}" & @CRLF & _
"{1,2,3,4,6,9,10,}" & @CRLF & _
"{5,4,3,2,1}" & @CRLF & _
"{1,2,3,4,5,6,7,8,9,10}" & @CRLF & _
"" & @CRLF & _
"{1,2,33,5,6,7,8,9,0,4}" & @CRLF & _
"{1,2,33,5,6,7,8,9,44}" & @CRLF & _
"" & @CRLF & _
"{331,2,989}" & @CRLF & _
"{331,2,989}" & @CRLF & _
"{331,2,98,9}" & @CRLF & _
"{331,2,989}" & @CRLF & _
"{1,2,3,4}" & @CRLF & _
"{1,2,1,4}" & @CRLF & _
"{1,2,3,4,6,9,10}" & @CRLF & _
"{5,4,3,2,1}" & @CRLF & _
"{1,2,3,4,6,9,}" & @CRLF & _
"{1,2,3,4,7,8,2345102}" & @CRLF & _
"{1,2,3,4,5,6,7,8,9,0}" & @CRLF & _
"{1,2,3,4,5,6,7,8,9,10}" & @CRLF & _
"{1,2,3,4,5,6,7,8,22}" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")