use strict;
my $str = '{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10,}
{5,4,3,2,1}
{1,2,3,4,5,6,7,8,9,10}
{1,2,33,5,6,7,8,9,0,4}
{1,2,33,5,6,7,8,9,44}
{331,2,989}
{331,2,989}
{331,2,98,9}
{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10}
{5,4,3,2,1}
{1,2,3,4,6,9,}
{1,2,3,4,7,8,2345102}
{1,2,3,4,5,6,7,8,9,0}
{1,2,3,4,5,6,7,8,9,10}
{1,2,3,4,5,6,7,8,22}
';
my $regex = qr/\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\})|(?=\}))){3,7}\}(?(DEFINE)(?<GetNum>(?!(?:\g{1}|\g{2}|\g{3}|\g{4}|\g{5}|\g{6}|\g{7}|\g{8}|\g{9}|\g{10})\b)\d+))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}