import re
regex = re.compile(r"\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\})|(?=\}))){3,7}\}(?(DEFINE)(?<GetNum>(?!(?:\g{1}|\g{2}|\g{3}|\g{4}|\g{5}|\g{6}|\g{7}|\g{8}|\g{9}|\g{10})\b)\d+))")
test_str = ("{331,2,989}\n"
"{1,2,3,4}\n"
"{1,2,1,4}\n"
"{1,2,3,4,6,9,10,}\n"
"{5,4,3,2,1}\n"
"{1,2,3,4,5,6,7,8,9,10}\n\n"
"{1,2,33,5,6,7,8,9,0,4}\n"
"{1,2,33,5,6,7,8,9,44}\n\n"
"{331,2,989}\n"
"{331,2,989}\n"
"{331,2,98,9}\n"
"{331,2,989}\n"
"{1,2,3,4}\n"
"{1,2,1,4}\n"
"{1,2,3,4,6,9,10}\n"
"{5,4,3,2,1}\n"
"{1,2,3,4,6,9,}\n"
"{1,2,3,4,7,8,2345102}\n"
"{1,2,3,4,5,6,7,8,9,0}\n"
"{1,2,3,4,5,6,7,8,9,10}\n"
"{1,2,3,4,5,6,7,8,22}\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")