const regex = /\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\})|(?=\}))){3,7}\}(?(DEFINE)(?<GetNum>(?!(?:\g{1}|\g{2}|\g{3}|\g{4}|\g{5}|\g{6}|\g{7}|\g{8}|\g{9}|\g{10})\b)\d+))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\\})|(?=\\}))){3,7}\\}(?(DEFINE)(?<GetNum>(?!(?:\\g{1}|\\g{2}|\\g{3}|\\g{4}|\\g{5}|\\g{6}|\\g{7}|\\g{8}|\\g{9}|\\g{10})\\b)\\d+))', 'g')
const str = `{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10,}
{5,4,3,2,1}
{1,2,3,4,5,6,7,8,9,10}
{1,2,33,5,6,7,8,9,0,4}
{1,2,33,5,6,7,8,9,44}
{331,2,989}
{331,2,989}
{331,2,98,9}
{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10}
{5,4,3,2,1}
{1,2,3,4,6,9,}
{1,2,3,4,7,8,2345102}
{1,2,3,4,5,6,7,8,9,0}
{1,2,3,4,5,6,7,8,9,10}
{1,2,3,4,5,6,7,8,22}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}