$re = '/\{(?>(?>(?(1)(?!))((?&GetNum))|(?(2)(?!))((?&GetNum))|(?(3)(?!))((?&GetNum))|(?(4)(?!))((?&GetNum))|(?(5)(?!))((?&GetNum))|(?(6)(?!))((?&GetNum))|(?(7)(?!))((?&GetNum))|(?(8)(?!))((?&GetNum))|(?(9)(?!))((?&GetNum))|(?(10)(?!))((?&GetNum)))(?:,(?!\})|(?=\}))){3,7}\}(?(DEFINE)(?<GetNum>(?!(?:\g{1}|\g{2}|\g{3}|\g{4}|\g{5}|\g{6}|\g{7}|\g{8}|\g{9}|\g{10})\b)\d+))/';
$str = '{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10,}
{5,4,3,2,1}
{1,2,3,4,5,6,7,8,9,10}
{1,2,33,5,6,7,8,9,0,4}
{1,2,33,5,6,7,8,9,44}
{331,2,989}
{331,2,989}
{331,2,98,9}
{331,2,989}
{1,2,3,4}
{1,2,1,4}
{1,2,3,4,6,9,10}
{5,4,3,2,1}
{1,2,3,4,6,9,}
{1,2,3,4,7,8,2345102}
{1,2,3,4,5,6,7,8,9,0}
{1,2,3,4,5,6,7,8,9,10}
{1,2,3,4,5,6,7,8,22}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);