package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)`)
var str = `Реклама
подпишитесь реклама dfdf 12321 нажми авторские права`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}