$re = '/(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)/iu';
$str = 'Реклама
подпишитесь реклама dfdf 12321 нажми авторские права';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);