re = /(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)/i
str = 'Реклама
подпишитесь реклама dfdf 12321 нажми авторские права'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end