// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?iu)(webmoney|сотрудн|коммерческих|заказа|промокод|почта|промокоды|промокоду|промокодом|промокоде|магазин|реклама|реклама|рекламы|4100|подпишись|подписывайся|авторские\sправа|подпишитесь|подписывайтесь|подписаться|присоединяйтесь|нажми|paypal)").unwrap();
let string = "Реклама
подпишитесь реклама dfdf 12321 нажми авторские права";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}