#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?:[^/]+/){2,4})category/(?:[^/]+/){2}/?$"
Local $sString = "country/destinations/itineraries/itinerary/category/region/country/" & @CRLF & _
"another/directory/category/region/country/" & @CRLF & _
"" & @CRLF & _
"country/destinations/itineraries/itinerary/" & @CRLF & _
"another/directory/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")