package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[^/]+/){2,4})category/(?:[^/]+/){2}/?$`)
var str = `country/destinations/itineraries/itinerary/category/region/country/
another/directory/category/region/country/
country/destinations/itineraries/itinerary/
another/directory/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}