$re = '@^((?:[^/]+/){2,4})category/(?:[^/]+/){2}/?$@m';
$str = 'country/destinations/itineraries/itinerary/category/region/country/
another/directory/category/region/country/
country/destinations/itineraries/itinerary/
another/directory/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);