using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:[^/]+/){2,4})category/(?:[^/]+/){2}/?$";
string input = @"country/destinations/itineraries/itinerary/category/region/country/
another/directory/category/region/country/
country/destinations/itineraries/itinerary/
another/directory/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}