// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((?:[^/]+/){2,4})category/(?:[^/]+/){2}/?$").unwrap();
let string = "country/destinations/itineraries/itinerary/category/region/country/
another/directory/category/region/country/
country/destinations/itineraries/itinerary/
another/directory/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}