#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)my_project\/output\/board1\/build\/foo.*"
Local $sString = "my_project/output/board1/build/foo-module1" & @CRLF & _
"my_project/output/board1/build/foo-module2" & @CRLF & _
"my_project/output/board1/build/foo-module3" & @CRLF & _
"..." & @CRLF & _
"my_project/output/board1/build/foo-module99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")