import re
regex = re.compile(r"my_project\/output\/board1\/build\/foo.*", flags=re.MULTILINE)
test_str = ("my_project/output/board1/build/foo-module1\n"
"my_project/output/board1/build/foo-module2\n"
"my_project/output/board1/build/foo-module3\n"
"...\n"
"my_project/output/board1/build/foo-module99")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")