import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "my_project\\/output\\/board1\\/build\\/foo.*";
final String string = "my_project/output/board1/build/foo-module1\n"
+ "my_project/output/board1/build/foo-module2\n"
+ "my_project/output/board1/build/foo-module3\n"
+ "...\n"
+ "my_project/output/board1/build/foo-module99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}