re = /my_project\/output\/board1\/build\/foo.*/m
str = 'my_project/output/board1/build/foo-module1
my_project/output/board1/build/foo-module2
my_project/output/board1/build/foo-module3
...
my_project/output/board1/build/foo-module99'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end