package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)my_project\/output\/board1\/build\/foo.*`)
var str = `my_project/output/board1/build/foo-module1
my_project/output/board1/build/foo-module2
my_project/output/board1/build/foo-module3
...
my_project/output/board1/build/foo-module99`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}