package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{4}(\d{2})?$`)
var str = `123413
87623
2342
342
12
4
412
3412
31123
2341234
23412342341234234123423412342341234234123423412342341234234123423
2341234234123423412342341234234123423412342341234234123423412342
234123423412342341234234123423412342341234234123423412342341234
23412342341234234123423412342341234234123423412342341234234123
234123423412342341234234123423412342341234234123423412342341
23412342341234234123423412342341234234123423412342341234234
4333
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}