// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{4}(\d{2})?$").unwrap();
let string = "123413
87623
2342
342
12
4
412
3412
31123
2341234
23412342341234234123423412342341234234123423412342341234234123423
2341234234123423412342341234234123423412342341234234123423412342
234123423412342341234234123423412342341234234123423412342341234
23412342341234234123423412342341234234123423412342341234234123
234123423412342341234234123423412342341234234123423412342341
23412342341234234123423412342341234234123423412342341234234
4333
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}