re = /^\d{4}(\d{2})?$/m
str = '123413
87623
2342
342
12
4
412
3412
31123
2341234
23412342341234234123423412342341234234123423412342341234234123423
2341234234123423412342341234234123423412342341234234123423412342
234123423412342341234234123423412342341234234123423412342341234
23412342341234234123423412342341234234123423412342341234234123
234123423412342341234234123423412342341234234123423412342341
23412342341234234123423412342341234234123423412342341234234
4333
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end