import Foundation
let pattern = #"^\d{4}(\d{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
123413
87623
2342
342
12
4
412
3412
31123
2341234
23412342341234234123423412342341234234123423412342341234234123423
2341234234123423412342341234234123423412342341234234123423412342
234123423412342341234234123423412342341234234123423412342341234
23412342341234234123423412342341234234123423412342341234234123
234123423412342341234234123423412342341234234123423412342341
23412342341234234123423412342341234234123423412342341234234
4333
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)