import re
regex = re.compile(r"^\d{4}(\d{2})?$", flags=re.MULTILINE)
test_str = ("123413\n"
"87623\n"
"2342\n"
"342\n"
"12\n"
"4\n"
"412\n"
"3412\n"
"31123\n"
"2341234\n"
"23412342341234234123423412342341234234123423412342341234234123423\n"
"2341234234123423412342341234234123423412342341234234123423412342\n"
"234123423412342341234234123423412342341234234123423412342341234\n"
"23412342341234234123423412342341234234123423412342341234234123\n"
"234123423412342341234234123423412342341234234123423412342341\n"
"23412342341234234123423412342341234234123423412342341234234\n"
"4333\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")