const regex = /^\d{4}(\d{2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}(\\d{2})?$', 'gm')
const str = `123413
87623
2342
342
12
4
412
3412
31123
2341234
23412342341234234123423412342341234234123423412342341234234123423
2341234234123423412342341234234123423412342341234234123423412342
234123423412342341234234123423412342341234234123423412342341234
23412342341234234123423412342341234234123423412342341234234123
234123423412342341234234123423412342341234234123423412342341
23412342341234234123423412342341234234123423412342341234234
4333
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}